4th December 2019

Shared Hosting sl-508-19.slc.westdc.net

We are aware that there are issues affecting this server. We are working to get them resolved.

  • Update @ Wed Dec 4 11:43:34 MST 2019 - This server is being rebooted to restore service.
  • Update @ Wed Dec 4 11:47:50 MST 2019 - This server is online and available for use.