15th March 2021

Hosted Email Hosted Email Issues - Email Delays

Title: Hosted Email Issues - Email Delays

Date: 15/03/2021

Please be advised that hosted email customers are experiencing a delay in inbound email. 3rd Party (Tucows) have acknowledged the issue and are investigating.

Update - We are still observing inbound email delays. Our engineering team is continuing to work on a resolution. We will provide further updates as soon as they become available.

Update - Our engineering team still works to clear out the inbound delays we are seeing improvements but there are still delays for some customers. We'll continue to provide updates as they come.

** Resolved** - Our engineering team was able to clear up the inbound delays, we haven't seen any further reports of delays. This incident is considered resolved.