8th June 2021

Hosted Email Inbound Delays

Investigating - We are currently experiencing inbound mail delays. Our engineering team is investigating the issue.

We will provide an update once we have additional information.

UPDATE ** RESOLVED** Our engineers have completed the investigation and all mail services are resumed to fully operational. Thankyou for you patience regarding during this issue.