8th July 2021

Hosted Email Hosted Email Inbound Delays

Title: Hosted Email Inbound Delays
Date: Thursday 8th July, 2020
Start time: 10:04 MDT

We are currently experiencing inbound mail delays on our hosted email platform. The Technical teams have been engaged and are investigating as a priority.

  • Update @ 10:50 MDT - The Engineering team has identified the issue, and are currently monitoring to confirm recoveries.
  • Update @ 11:28 MDT - The engineering team had correctly identified the cause of the delays. Changes were made and after monitoring the result we see message delivery back to normal performance.
    We apologise for the inconvenience this may have caused.