17th September 2021

Hosted Email Hosted Email Login Issue

Title Hosted Email Login Issue

Date Friday 17 September 2021

Start time 16:43 BST

We are experiencing intermittent login failure. We will provide an update shortly with additional information.

Update: @ 17:15 BST - We are currently investigating a login issue for a small set of customers with (Webmail, POP, IMAP). Users are facing issues with login. The engineering team has been engaged and is currently investigating the cause of this issue.

Update: @ 17:55 BST - We are monitoring and have initiated measures to restore service for our cluster A users, we will be continuing to monitor to ensure stability. As of now, users should be able to log back into their webmail for use.

Update: @ 18:15 BST - Hosted Email Login Issue (Webmail, POP, IMAP) have been resolved. Thank you for your patience whilst we resolved this fault.