28th July 2022

Email - Webmail Portal

Title: Email - Webmail Portal Date: Thursday July, 2022
Start time 14:31 MDT

We are aware of an issue with sending and receiving mail out by the webmail service for some customers.

Our engineers are investigating the issue.

Update Our technical teams have identified the issue and are working to resolve the problem as quickly as possible. Thank you for your patience.

Update @15.01 MDT This issue has now been resolved.