9th January 2017

Shared Hosting sl-508-12.slc.westdc.net

We are aware that there are issues affecting this server. We are working to get them resolved.

  • Update 10:20 MST - We have identified the issue with this server are are working to resolve them as quickly as possible.
  • Update 11:15 MST - We are still working on resolving issues with this server.
  • Update 13:17 MST - All services are up and available for use.