10th January 2017

Shared Hosting sl-508-10.slc.westdc.net

We are aware that there are issues affecting this server. We are working to get them resolved.

  • Update @ Tue Jan 10 18:54:10 MST 2017 - The server was under attack causing high load. We are taking steps to mitigate the attack.
  • Update @ Tue Jan 10 19:05:56 MST 2017 - The server is now operating normally.