26th March 2017

Shared Hosting sl-508-14

We are aware that there are issues affecting this server. We are working to get them resolved.

  • Update @ Sun Mar 26 18:36:49 MDT 2017 - Server was overloading/unresponsive and has been rebooted to restore service.

  • Update @ Sun Mar 26 18:51:11 MDT 2017 - The server has rebooted and malicious traffic blocked.