29th March 2017

Shared Hosting sl-508-17.slc.westdc.net

We are aware that there are issues affecting this server. We are working to get them resolved.

  • Update 5:02 a.m. MDT: The server became unresponsive due to high load and is being rebooted to restore service.
  • Update 5:05 a.m. MDT: The server is online and available for use.