19th April 2017

Shared Hosting dl-573-31

We are aware that there are issues affecting this server. We are working to get them resolved.

  • Update 11:42 MDT - This server has become non responsive and is being rebooted to restore service.
  • Update 11:49 MDT - Services are now available and accessible on this server.