23rd April 2017

Shared Hosting 508-17

We are aware that there are issues affecting this server. We are working to get them resolved.

Update 6:57 AM MDT: The server has been rebooted.

Update 7:05 AM MDT: The server is now back online.