8th June 2017

Shared Hosting wsl01028

We are aware that there are issues affecting this server. We are working to get them resolved.

  • Update 11:05 MDT - This server has been rebooted to restore service.
  • Update 11:55 MDT - All services are available for use and resource usage has returned to normal levels.