2nd August 2017

Email Services - Delivery Delays

We are currently investigating intermittent errors when connecting to mailboxes over IMAP, POP3, and Webmail. Users may intermittently experience errors when trying to send or receive mail. Our operations team is investigating the issue. Aug 2, 09:53 UTC

  • Update The operations team has implemented a fix to address the issue affecting intermittent connection to mailboxes. We will continue to monitor the issue for now updates if the status changes. Aug 2, 10:34 UTC
  • Update Our operations team has identified sporadic connectivity across IMAP, POP3, and Webmail services. We will update this incident once we have more information. Aug 2, 11:40 UTC
  • Update The issues should now be resolved. Aug 2, 11:59 UTC