28th September 2017

CHI Mail - Network Issues

Identified @ Sep 28, 07:44 MDT - Our operations team has identified network connectivity issues. This is causing degraded performance loading our control panels as well as webmail. We are working to restore service as quickly as possible and will update this status once we have more information.

We apologise for the inconvenience.

  • Update @ Sep 28, 08:48 MDT - Our operations team continues to work on stabilizing the network. Email service may still be degraded for some users.

  • Update @ Sep 28, 09:52 MDT - Our operations team is still working on resolving the issue as quickly as possible.

  • Update @ Sep 29 01:05 am MDT - The operations team has made progress towards resolution and most services have been restored. We still see reports where some sites and services are offline intermittently or due to DNS caching. DNS services are still recovering and may respond slowly or intermittently.

  • Update @ Sep 29 02:35 am MDT - The DNS service continues to experience issues intermittently and impacts the mail services. Thank you in advance for your patience as we continue to work through this service disruption.

  • Update @ Sep 29 4:55 am MDT - Our operations team has been all hands on deck this morning working to resolve the issue. We are now seeing significant improvement to the intermittent DNS issue impacting the services, however services are not fully restored yet. The operations team is working as quickly as possible to fully restore service but no ETA has been publish. We will continue to provide updates through this communication channel as we progress through the issue. Thank you for your patience.

  • Update @ Sep 29 6:54 am MDT - We are happy to report that this time the mail services are responding reliably. Throughout the service interruption third party mail providers will have queued up mail for delivery to our system. Delayed mail will be delivered throughout the day as per the third party mail providers delayed sending policy. We are still monitoring the systems to ensure they remain fully functional and will continue to provide updates until we are confident this is fully resolved.

  • Update @ Sep 29 7:25 am MDT - We've been monitoring the stability of our services and now consider this issue resolved. We will continue to monitor the problem and provide an update if the status changes. We expect to see inbound mail delivery delays as third party mail providers will have queued up mail for delivery to our system. Delayed mail will be delivered throughout the day as per the third party mail providers delayed sending policy. Thank you for your patience as we worked through this issue.

  • Update @ Sep 29 9:08 am MDT - This incident has been resolved.