5th October 2018

Web Hosting sl-507-9.slc.westdc.net

We are aware that there are issues affecting this server. We are working to get them resolved. The server has been rebooted and started a file system check.

Update @ Fri October 5 17:25 MDT 2018: The file system check is at 38%.

Update @ Fri October 5 17:43 MDT 2018: The server is up and running.