1st October 2019

Phone & Chat Service

RESOLVED: Technical teams have fixed the issue. Our chat and phone service is back operational.

ISSUE: Please be advised we are currently experiencing technical issues with our phone and chat services. Technical teams are currently investigating the issue. In the meantime, please visit https://www.westhost.com/support/ to log a ticket for our support staff.