4th February 2020

Shared Hosting sl-508-3.slc.westdc.net, sl-507-11.slc.westdc.net

We are aware that there are issues affecting the Cpanel email on the server sl-508-3.slc.westdc.net and sl-507-11.slc.westdc.net. We are working to get them resolved.

  • Update Monday, 3 February 2020, 23:30 MST. We will provide an update once we have additional information.

  • Update Tuesday, 4 February 2020, 04:32 MST - This issue has been identified, and a fix has been implemented.