14th October 2016

Web Hosting Initial Outage wsl02020

We are aware that there are issues affecting this server. We are working to get them resolved.

Update 11:40 a.m. MDT - The server is receiving a full file system check.

Update 1:11 p.m. MDT - The last remaining file system being checked is at 20%

Update 2:37 p.m. MDT - This server is back online and accounts are starting up.