17th March 2021

Hosted Email Webmail Issue - Email Delays

We are currently experiencing inbound delays for E-mail for some users due to a queue buildup.
Our Mail Admin team are investigating to determine the root cause and working to improve the situation.

Thank you for your patience and understanding.

UPDATE - Our engineering team continues to work on managing the queue buildup and improving mail delivery time.

We will provide updates as they are available.

UPDATE - Our engineering team continues to investigate the root cause of the issue and we will continue to provide updates.

RESOLVED - A fix has been implemented and the issue for the email delays is now be resolved.

Thankyou for you patience during this issue.