11th February 2022

Dedicated Servers/VPS VPS Seattle-B Unavailable

Title Seattle-B Unavailable
Date Friday 11 Feb 2022
Start time 01:20 MDT

We are currently experiencing an incident that is impacting our Seattle-B cloud. Our Technical teams have been engaged and are investigating as a priority.

Update @ 03:20 MDT - We have identified the issue with the Seattle-B cloud. Our technical teams are working to restore access to machines as the highest priority

Resolved A fix has been implemented. Services have returned to normal, and we will continue to monitor this. Thank you for your patience and our apologies for any inconvenience caused.