2nd November 2022

Shared hosting server Unavailable

Title sl-507-7.slc.westdc.net Unavailable
Date Wednesday 02/11/2022
Start time 15:00 MDT

We are currently experiencing an incident on the server sl-507-7.slc.westdc.net. Our Technical teams have been engaged and are investigating as a priority.

Update Our technical teams have identified the issue and are working to resolve the problem as quickly as possible. Thank you for your patience.

Update @ 03:50 MDT - This issue has been resolved