7th April 2023

Shared Hosting Shared hosting server Unavailable

Title: sl-508-27.slc.westdc.net Unavailable
Date: 07/04/2023
Start time: 13:02 MDT

We are currently experiencing an incident on the server sl-508-27.slc.westdc.net Our Technical teams have been engaged and are investigating as a priority.

Update Our technical teams have identified the issue and are working to resolve the problem as quickly as possible. Thank you for your patience.

Update @14.30 MDT This issue has now been resolved.