WestHost Status
Home
Support
Login
WestHost.com Home
All Products
1.800.222.2165
29th November 2016
Web Hosting
wsl01015
We are aware that there are issues affecting this server. We are working to get them resolved.
Update 9:48 MST - This server became non responsive and is being rebooted.
Update 10:37 MST - This server is up and available for use.