Back to overview
Resolved

Issues with Order Payments and Processing

Sep 23, 2026 at 8:32am UTC
Affected services
Westhost Website
CHI (Control Panel)
Stack CP (Hosting Control Panel)
Stack Webmail

Resolved
Sep 23, 2026 at 9:09am UTC

The issue affecting a third-party payment provider has now been resolved.

Customers should no longer experience failures when placing orders, and order processing is now operating as expected. We have continued to monitor the situation following recovery and have seen services return to normal.

We apologise for any inconvenience caused and thank customers for their patience while the provider worked to restore service.

Created
Sep 23, 2026 at 8:32am UTC

We are aware of an issue currently affecting a third-party payment provider.

As a result, some customers may experience failures when placing orders, and there may be delays in the processing of successfully submitted orders.

We are actively monitoring the situation and working closely with the provider to restore normal service as quickly as possible. We apologise for any inconvenience this may cause and will provide further updates as more information becomes available.