IMPORTANT: Critical Vulnerability in Linux Kernel
Created
Apr 30, 2026 at 7:00am UTC
We are actively mitigating a recently disclosed vulnerability (the "copy fail" CVE) in the Linux kernel, affecting components of our infrastructure. Patching is underway across our fleet.
What to expect:
Brief, intermittent service interruptions are possible throughout the day as servers are rebooted to apply mitigations.
Reboots may occur without advance warning to ensure timely remediation and protect customer data.
We expect individual reboots to be short, but some requests in flight may fail and need to be retried.
What we're doing:
Rolling out patches and rebooting affected systems on an accelerated timeline.
Monitoring for impact and prioritizing customer-facing services.
We appreciate your patience as we prioritize the security of the platform. We will post further updates here as mitigation progresses and a final update once all systems are confirmed patched.
Affected services