DNS Name Server Issue
Updated
Jun 11, 2026 at 12:51pm UTC
A fix has been applied and we are seeing DNS propagation improve across the infrastructure. Some users may continue to experience intermittent issues while the changes finish spreading across global DNS resolvers, but the situation is improving.
We will continue to monitor closely and will confirm full resolution once propagation is complete. Thank you for your patience.
Affected services
Created
Jun 11, 2026 at 12:03pm UTC
We are currently experiencing an issue with DNS propagation on nameservers dns1-3.westhost.com that is causing intermittent disruption to some of our services, including website availability and email delivery. Our team is actively investigating.
Affected services