Back to overview
Degraded
Issue: American Express Payments
Jun 15, 2026 at 2:27pm UTC
Affected services
Westhost Website
Created
Jun 15, 2026 at 2:27pm UTC
We are aware of a problem affecting American Express payments and are working to fix it. We recommend using an alternative payment method while we investigate.
We'll update this page with progress as soon as possible. Thank you for your patience.
Affected services