Back to overview
Resolved
Live Chat and Ticketing System
Jul 10, 2026 at 12:44pm UTC
Affected services
Westhost Website
CHI (Control Panel)
Stack CP (Hosting Control Panel)
Stack Webmail
Resolved
Jul 10, 2026 at 1:19pm UTC
Our live chat and ticketing system have now been restored and are operating normally.
Thank you for your patience while we resolved the issue. We apologise again for any inconvenience caused, and we appreciate your understanding.
Affected services
Created
Jul 10, 2026 at 12:44pm UTC
Our live chat and ticketing system is currently unavailable. Our team is actively working to resolve the issue and restore normal service as soon as possible.
We apologise for any inconvenience this may cause and appreciate your patience. We will provide further updates shortly.
Affected services